传智播客旗下技术交流社区北京校区

 找回密码
 加入黑马

QQ登录

只需一步,快速开始

© 播妞 黑马官方管理员   /  2018-7-11 17:26  /  2115 人查看  /  91 人回复  /   2 人收藏 转载请遵从CC协议 禁止商业使用本文

课程介绍

Laravel框架是世界上最流行的PHP开发框架,没有之一,本课程主要是轻松学会Laravel基础视频教程+实战教程,现在Laravel框架已成为大型互联网公司及PHP攻城狮们的首选框架,最新视频已发布,带你全面掌握对应知识点,助你学有所成!

本次课程简介

01.laravel介绍

02.使用composer创建laravel项目

03.目录结构

04.框架的启动方式

05.路由规则的使用加片尾...

... ....

部分资料展示

1、简介
Laravel是一套简洁,优雅的PHP WEB开发框架(PHP Web Framework)。
laravel是目前一个比较主流的框架,现在很多互联网的公司基本都在使用该框架。该框架是基于symfony【国外一款非常流行的框架:由于国内手册不是很齐全,没有多少公司使用】的一个国外的MVC框架。诞生于2011年6月11日
官网:https://laravel.com/
中文官网:http://www.golaravel.com/
中文社区:https://laravel-china.org/
Laravel框架的广告语:
WEB 艺术家创造的 PHP 框架
目前大部分的框架公共的特点(了解):
(1)单入口,所有的请求必须从单入口开始,主要是便于管理(统一的参数过滤)
(2)MVC的思想(分层思想,主要是为了协同开发,实现后期的维护方便)
(3)ORM操作数据库(Object Relations Model):AR模式
注意:Laravel框架有一个特点,所有的URL访问都必须事先定好路由规则。
2、开发环境配置与要求
Laravel框架的运行对环境是有严格要求的。
图片1.png

php.ini配置文件需要开启的扩展:
extension=php_openssl.dll
extension=php_pdo_mysql.dll
extension=php_mbstring.dll
extension=php_fileinfo.dll(验证码代码依赖需要该扩展)
extension=php_curl.dll(主要用于请求的发送)

httpd.conf配置文件需要开启的模块:
LoadModule deflate_module modules/mod_deflate.so
LoadModule rewrite_module modules/mod_rewrite.so

如果php的版本不满足基本要求需要升级,则有2个方法可供使用:
a. 使用带有符合要求的php版本的集成环境替换当前环境(phpstudy),如当前数据库的数据仍需要,则需要备份下数据库,在装好新的环境之后导入备份的数据库;
b. apachemysql不做任何替换操作,单独的下载符合要求的版本php,替换原先低版本的php
c. 建议php使用php7+版本
节选自第一部分部分资料

网盘资料截图
未标题-1.jpg

本次教程链接已添加,需要的回帖下载哦~

游客,如果您要查看本帖隐藏内容请回复

分享至 : QQ空间
收藏

91 个回复

倒序浏览
学习一下!~
回复 使用道具 举报
学习一下!
回复 使用道具 举报
感谢分享!!!
回复 使用道具 举报
支持支持
回复 使用道具 举报
多谢分享
回复 使用道具 举报
学习一下
回复 使用道具 举报
我要.....................................
回复 使用道具 举报
我要学嘻嘻嘻嘻
回复 使用道具 举报
资源很好
回复 使用道具 举报
好资料抢先看
回复 使用道具 举报
学习一下
回复 使用道具 举报

多谢分享
回复 使用道具 举报
谢谢写写谢谢谢谢谢写写谢谢谢谢谢写写谢谢谢
回复 使用道具 举报
666666666666
回复 使用道具 举报
感谢分享
回复 使用道具 举报
免费资源
回复 使用道具 举报
想学习一下啊
回复 使用道具 举报
啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊
回复 使用道具 举报
不错哦,值得看看。。。。。。。。
回复 使用道具 举报
12345下一页
您需要登录后才可以回帖 登录 | 加入黑马
关闭

站长推荐 上一条 /5 下一条